Mentions légales du service

Skip to content
Snippets Groups Projects
Commit 5a2932b7 authored by Thomas Moulard's avatar Thomas Moulard
Browse files

Add patch to fix portability issue in vpLex.c (see #723803)

parent 7dd335d0
No related branches found
No related tags found
No related merge requests found
......@@ -11,10 +11,10 @@ Forwarded: no (not relevant)
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fdcb0b0..78f649b 100644
index f83aaf5..18764c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2033,7 +2033,7 @@ EXPORT_LIBRARY_DEPENDENCIES(
@@ -2041,7 +2041,7 @@ CMAKE_EXPORT_BUILD_SETTINGS(
# Install vpConfig.h that may differ from the one in include/visp
INSTALL(FILES ${VISP_BINARY_DIR}/install/vpConfig.h
......
From: Thomas Moulard <thomas.moulard@gmail.com>
Date: Thu, 26 Sep 2013 12:26:42 +0900
Subject: Fix vpLex.c portability issue.
Author: Rebecca N. Palmer <r.palmer@bham.ac.uk>
Forwarded: yes
---
src/simulator/wireframe-simulator/core/vpLex.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/simulator/wireframe-simulator/core/vpLex.c b/src/simulator/wireframe-simulator/core/vpLex.c
index 366dfc3..e56a097 100755
--- a/src/simulator/wireframe-simulator/core/vpLex.c
+++ b/src/simulator/wireframe-simulator/core/vpLex.c
@@ -239,9 +239,9 @@ void close_lex (void)
#define ECHO printf ("%c", *(mysptr))
-#define CURC (*mysptr) /* caractere courant */
-#define NEXTC (*(mysptr+1)) /* caractere suivant */
-#define PREVC (*(mysptr-1)) /* caractere precedent */
+#define CURC (*((signed char *)mysptr)) /* caractere courant */
+#define NEXTC (*((signed char *)mysptr+1)) /* caractere suivant */
+#define PREVC (*((signed char *)mysptr-1)) /* caractere precedent */
/*
0001-Install-vpConfig.h-in-include-architecture-triplet.patch
0002-Fix-vpLex.c-portability-issue.patch
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment