diff --git a/debian/patches/0001-Install-vpConfig.h-in-include-architecture-triplet.patch b/debian/patches/0001-Install-vpConfig.h-in-include-architecture-triplet.patch
index 9327ca6881f6027c00a9c0942d8bdce10ea85c84..8b817eb838313215b42c44c5e601ebc9342ffc93 100644
--- a/debian/patches/0001-Install-vpConfig.h-in-include-architecture-triplet.patch
+++ b/debian/patches/0001-Install-vpConfig.h-in-include-architecture-triplet.patch
@@ -11,10 +11,10 @@ Forwarded: no (not relevant)
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index fdcb0b0..78f649b 100644
+index f83aaf5..18764c4 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -2033,7 +2033,7 @@ EXPORT_LIBRARY_DEPENDENCIES(
+@@ -2041,7 +2041,7 @@ CMAKE_EXPORT_BUILD_SETTINGS(
  
  # Install vpConfig.h that may differ from the one in include/visp
  INSTALL(FILES ${VISP_BINARY_DIR}/install/vpConfig.h
diff --git a/debian/patches/0002-Fix-vpLex.c-portability-issue.patch b/debian/patches/0002-Fix-vpLex.c-portability-issue.patch
new file mode 100644
index 0000000000000000000000000000000000000000..41666f3d04ca705efe877c43475290803ff90044
--- /dev/null
+++ b/debian/patches/0002-Fix-vpLex.c-portability-issue.patch
@@ -0,0 +1,27 @@
+From: Thomas Moulard <thomas.moulard@gmail.com>
+Date: Thu, 26 Sep 2013 12:26:42 +0900
+Subject: Fix vpLex.c portability issue.
+
+Author: Rebecca N. Palmer <r.palmer@bham.ac.uk>
+Forwarded: yes
+---
+ src/simulator/wireframe-simulator/core/vpLex.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/simulator/wireframe-simulator/core/vpLex.c b/src/simulator/wireframe-simulator/core/vpLex.c
+index 366dfc3..e56a097 100755
+--- a/src/simulator/wireframe-simulator/core/vpLex.c
++++ b/src/simulator/wireframe-simulator/core/vpLex.c
+@@ -239,9 +239,9 @@ void close_lex (void)
+ 
+ 
+ #define	ECHO	printf ("%c", *(mysptr))
+-#define	CURC	(*mysptr)	/* caractere courant	*/
+-#define	NEXTC	(*(mysptr+1))	/* caractere suivant	*/
+-#define	PREVC	(*(mysptr-1))	/* caractere precedent	*/
++#define	CURC	(*((signed char *)mysptr))	/* caractere courant	*/
++#define	NEXTC	(*((signed char *)mysptr+1))	/* caractere suivant	*/
++#define	PREVC	(*((signed char *)mysptr-1))	/* caractere precedent	*/
+ 
+ 
+ /*
diff --git a/debian/patches/series b/debian/patches/series
index 232426fb984427c52bc7b0729a1548a60bdc42be..7905d4a8ffcd83f8aa717d134b1cadaacc520113 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
 0001-Install-vpConfig.h-in-include-architecture-triplet.patch
+0002-Fix-vpLex.c-portability-issue.patch