From 5a2932b772db358c67386847ebb3b7d0832c3b0b Mon Sep 17 00:00:00 2001
From: Thomas Moulard <thomas.moulard@gmail.com>
Date: Thu, 26 Sep 2013 12:33:52 +0900
Subject: [PATCH] Add patch to fix portability issue in vpLex.c (see #723803)

---
 ...ig.h-in-include-architecture-triplet.patch |  4 +--
 .../0002-Fix-vpLex.c-portability-issue.patch  | 27 +++++++++++++++++++
 debian/patches/series                         |  1 +
 3 files changed, 30 insertions(+), 2 deletions(-)
 create mode 100644 debian/patches/0002-Fix-vpLex.c-portability-issue.patch

diff --git a/debian/patches/0001-Install-vpConfig.h-in-include-architecture-triplet.patch b/debian/patches/0001-Install-vpConfig.h-in-include-architecture-triplet.patch
index 9327ca68..8b817eb8 100644
--- a/debian/patches/0001-Install-vpConfig.h-in-include-architecture-triplet.patch
+++ b/debian/patches/0001-Install-vpConfig.h-in-include-architecture-triplet.patch
@@ -11,10 +11,10 @@ Forwarded: no (not relevant)
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index fdcb0b0..78f649b 100644
+index f83aaf5..18764c4 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -2033,7 +2033,7 @@ EXPORT_LIBRARY_DEPENDENCIES(
+@@ -2041,7 +2041,7 @@ CMAKE_EXPORT_BUILD_SETTINGS(
  
  # Install vpConfig.h that may differ from the one in include/visp
  INSTALL(FILES ${VISP_BINARY_DIR}/install/vpConfig.h
diff --git a/debian/patches/0002-Fix-vpLex.c-portability-issue.patch b/debian/patches/0002-Fix-vpLex.c-portability-issue.patch
new file mode 100644
index 00000000..41666f3d
--- /dev/null
+++ b/debian/patches/0002-Fix-vpLex.c-portability-issue.patch
@@ -0,0 +1,27 @@
+From: Thomas Moulard <thomas.moulard@gmail.com>
+Date: Thu, 26 Sep 2013 12:26:42 +0900
+Subject: Fix vpLex.c portability issue.
+
+Author: Rebecca N. Palmer <r.palmer@bham.ac.uk>
+Forwarded: yes
+---
+ src/simulator/wireframe-simulator/core/vpLex.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/simulator/wireframe-simulator/core/vpLex.c b/src/simulator/wireframe-simulator/core/vpLex.c
+index 366dfc3..e56a097 100755
+--- a/src/simulator/wireframe-simulator/core/vpLex.c
++++ b/src/simulator/wireframe-simulator/core/vpLex.c
+@@ -239,9 +239,9 @@ void close_lex (void)
+ 
+ 
+ #define	ECHO	printf ("%c", *(mysptr))
+-#define	CURC	(*mysptr)	/* caractere courant	*/
+-#define	NEXTC	(*(mysptr+1))	/* caractere suivant	*/
+-#define	PREVC	(*(mysptr-1))	/* caractere precedent	*/
++#define	CURC	(*((signed char *)mysptr))	/* caractere courant	*/
++#define	NEXTC	(*((signed char *)mysptr+1))	/* caractere suivant	*/
++#define	PREVC	(*((signed char *)mysptr-1))	/* caractere precedent	*/
+ 
+ 
+ /*
diff --git a/debian/patches/series b/debian/patches/series
index 232426fb..7905d4a8 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
 0001-Install-vpConfig.h-in-include-architecture-triplet.patch
+0002-Fix-vpLex.c-portability-issue.patch
-- 
GitLab