Une MAJ de sécurité est nécessaire sur notre version actuelle. Elle sera effectuée lundi 02/08 entre 12h30 et 13h. L'interruption de service devrait durer quelques minutes (probablement moins de 5 minutes).

  • GILLES Sebastien's avatar
    #859 Petsc: add wrappers to use MatPtAP. However it doesn't seem to work at... · e7480106
    GILLES Sebastien authored
    #859 Petsc: add wrappers to use MatPtAP. However it doesn't seem to work at the moment: PETSC_DEFAULT doesn't work for fill parameter, and the one I compute doesn't respect their constraint fill >= 1. I have contacted Petsc developers to help me on that topic; in the time being MatMatMult followed by MatTransposeMatMult do the job, albeit probably much less efficiently.
    e7480106
MatrixOperations.hpp 21.6 KB