Commit 99c99cf7 authored by Sylvain Dailler's avatar Sylvain Dailler

ide: Force the use of a recent lablgtk

In earlier version, the parameter ~parent of GToolbox.question_box does
not exist. More recent version depends from OCaml version 4.06.0 or higher.
Hence the choice for lablgtk 2.18.7.
parent cbd77699
......@@ -593,6 +593,13 @@ if test "$enable_ide" = retry; then
fi
AC_CHECK_FILE($DIR/gtkButton.cmi,,enable_ide=no)
if test "$enable_ide" = yes; then
# Test for lablgtk version greater than 2.18.7: most recent version
# available for OCaml 4.05.0.
LABLGTKVER=$(grep "^version =" $DIR/META 2> /dev/null | \
sed -e "s/version = \"//" -e "s/\"//")
AX_VERSION_GE([$LABLGTKVER], 2.18.7, [],
[AC_MSG_ERROR(You need lablgtk version 2.18.7 or higher.)])
# Set Gtk version
GTKVERSION=2
reason_ide=" (gtk2)"
else
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment