Attention une mise à jour du service Gitlab va être effectuée le mardi 30 novembre entre 17h30 et 18h00. Cette mise à jour va générer une interruption du service dont nous ne maîtrisons pas complètement la durée mais qui ne devrait pas excéder quelques minutes. Cette mise à jour intermédiaire en version 14.0.12 nous permettra de rapidement pouvoir mettre à votre disposition une version plus récente.

Commit 69a8b5e8 authored by MARCHE Claude's avatar MARCHE Claude
Browse files

updated roadmap after strange conflict

parent 76617da9
...@@ -8,13 +8,6 @@ ...@@ -8,13 +8,6 @@
* more libraries (theories and modules) * more libraries (theories and modules)
* WhyML
** regions : strong update
** clone module
** ghost code
** extraction of Ocaml code
** logic symbols used in programs
* A true Jessie3 front-end ? * A true Jessie3 front-end ?
* traceability: Partially done * traceability: Partially done
...@@ -61,6 +54,10 @@ ...@@ -61,6 +54,10 @@
le bon typage, et clone sera en premier lieu un de ces constructors le bon typage, et clone sera en premier lieu un de ces constructors
** cas d'utilisation: range d'entiers de Jessie, Flottants -> double ou single ** cas d'utilisation: range d'entiers de Jessie, Flottants -> double ou single
containeurs pour Adacore et Claire containeurs pour Adacore et Claire
NON PRIORITAIRE ?
** regions : strong update
** ghost code
** logic symbols used in programs
* extraction vers Caml * extraction vers Caml
** PRIORITAIRE, JCF, ANDREI, besoin pour cours aux JFLA en janvier 2012 ** PRIORITAIRE, JCF, ANDREI, besoin pour cours aux JFLA en janvier 2012
...@@ -98,9 +95,18 @@ ...@@ -98,9 +95,18 @@
* DELAYED Coq plugin * DELAYED Coq plugin
* Coq realization of theories * Coq realization of theories
** corriger l'incoherence ** corriger l'incoherence, comprendre si on veut vraiment accepter
function x : 'a
(cf: en caml cela ne marche pas)
** make it really usable
** understand problems when trying to realize set.why.
Status of equality, relation with clone module feature
* DOC: * DOC:
** document new tools why3stats and others if any
** complete api.tex: explain how to build theories, apply ** complete api.tex: explain how to build theories, apply
transformations, write new functions on terms (A) transformations, write new functions on terms (A)
** complete manpages.tex: section "Drivers of external provers" (A+F) ** complete manpages.tex: section "Drivers of external provers" (A+F)
...@@ -110,6 +116,7 @@ ...@@ -110,6 +116,7 @@
** saving session ** saving session
* add "ctrl-S" to save the session explicitly * add "ctrl-S" to save the session explicitly
(partially done, but no shortcut) (partially done, but no shortcut)
* do not save if no change was made
** restore provers detection in the middle of a session. ** restore provers detection in the middle of a session.
+ todo: run detection immediately at start up if conf file absent or + todo: run detection immediately at start up if conf file absent or
outdated. should become doable with the new Session module outdated. should become doable with the new Session module
......
[ATP alt-ergo-0.93.1]
name = "Alt-Ergo"
exec = "alt-ergo-0.93.1"
version_switch = "-version"
version_regexp = "\\([0-9.]+\\)"
version_ok = "0.93.1"
version_bad = "0.93"
version_bad = "0.92.3"
version_bad = "0.92.2"
version_bad = "0.92.1"
version_bad = "0.92"
version_bad = "0.91"
version_bad = "0.9"
version_bad = "0.8"
command = "@LOCALBIN@why3-cpulimit %t %m -s %e %f"
driver = "drivers/alt_ergo_trunk.drv"
[ATP alt-ergo] [ATP alt-ergo]
name = "Alt-Ergo" name = "Alt-Ergo"
exec = "alt-ergo" exec = "alt-ergo"
version_switch = "-version" version_switch = "-version"
version_regexp = "\\([0-9.]+\\)" version_regexp = "\\([0-9.]+\\)"
version_ok = "0.93.1"
version_ok = "0.93" version_ok = "0.93"
version_bad = "0.92.3" version_bad = "0.92.3"
version_bad = "0.92.2" version_bad = "0.92.2"
...@@ -47,9 +31,9 @@ version_old = "0.8" ...@@ -47,9 +31,9 @@ version_old = "0.8"
command = "@LOCALBIN@why3-cpulimit %t %m -s %e %f" command = "@LOCALBIN@why3-cpulimit %t %m -s %e %f"
driver = "drivers/alt_ergo.drv" driver = "drivers/alt_ergo.drv"
[ATP cvc3-2.4] [ATP cvc3]
name = "CVC3" name = "CVC3"
exec = "cvc3-2.4.1" exec = "cvc3"
version_switch = "-version" version_switch = "-version"
version_regexp = "This is CVC3 version \\([^ \n]+\\)" version_regexp = "This is CVC3 version \\([^ \n]+\\)"
version_ok = "2.4.1" version_ok = "2.4.1"
...@@ -157,9 +141,9 @@ command = "@LOCALBIN@why3-cpulimit %t %m -s %e %f" ...@@ -157,9 +141,9 @@ command = "@LOCALBIN@why3-cpulimit %t %m -s %e %f"
driver = "drivers/verit.drv" driver = "drivers/verit.drv"
[ATP z3-3] [ATP z3]
name = "Z3" name = "Z3"
exec = "z3-3.2" exec = "z3"
version_switch = "-version" version_switch = "-version"
version_regexp = "Z3 version \\([^ \n\r]+\\)" version_regexp = "Z3 version \\([^ \n\r]+\\)"
version_ok = "3.2" version_ok = "3.2"
...@@ -181,7 +165,7 @@ name = "Z3" ...@@ -181,7 +165,7 @@ name = "Z3"
exec = "z3" exec = "z3"
version_switch = "-version" version_switch = "-version"
version_regexp = "Z3 version \\([^ \n\r]+\\)" version_regexp = "Z3 version \\([^ \n\r]+\\)"
version_ok = "2.19" version_old = "2.19"
version_old = "2.18" version_old = "2.18"
version_old = "2.17" version_old = "2.17"
version_old = "2.16" version_old = "2.16"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment