Commit 9b1f8f55 authored by Mathieu Giraud's avatar Mathieu Giraud

fuse.py, should-vdj-to-tap.py: checks for Python >= 2.7

Note that the check will work on Python 2.6, but not on Python 2.4.
parent 65fbf581
...@@ -15,6 +15,12 @@ The 'should_pattern' is then checked against the 'result' part, and a .tap file ...@@ -15,6 +15,12 @@ The 'should_pattern' is then checked against the 'result' part, and a .tap file
''' '''
import sys import sys
PY_REQUIRED = (2, 7)
if sys.version_info < PY_REQUIRED:
print("This script requires Python >= %d.%d." % (PY_REQUIRED))
sys.exit(1)
from subprocess import Popen, PIPE, STDOUT from subprocess import Popen, PIPE, STDOUT
import os import os
......
...@@ -26,9 +26,16 @@ ...@@ -26,9 +26,16 @@
# along with "Vidjil". If not, see <http://www.gnu.org/licenses/> # along with "Vidjil". If not, see <http://www.gnu.org/licenses/>
from __future__ import print_function from __future__ import print_function
import sys
PY_REQUIRED = (2, 7)
if sys.version_info < PY_REQUIRED:
print("This script requires Python >= %d.%d." % (PY_REQUIRED))
sys.exit(1)
import json import json
import argparse import argparse
import sys
import time import time
import copy import copy
import os.path import os.path
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment