Commit 5c3f2c7a authored by Mathieu Giraud's avatar Mathieu Giraud

algo/: Vidjil now requires C++11

As C++11 compilation is not universal now, here are some hints for the user.
parent 06ba9f49
......@@ -49,7 +49,7 @@ The results of these automated tests can be checked on [[https://travis-ci.org/v
To install and use Vidjil on a computer, make sure:
- to be on a POSIX system ;
- to have a C++ compiler ;
- to have a C++11 compiler ;
- to have the =zlib= installed (=zlib1g-dev= package under Debian/Ubuntu,
=zlib-devel= package under Fedora/CentOS).
......@@ -76,6 +76,14 @@ make test # run self-tests
./vidjil -h # display help/usage
#+END_SRC
** C++11 Compilation
If your build system does not use C++11 by default, you should try:
make CXXFLAGS='-std=gnu++0x' ### gcc-4.6 (as in Ubuntu 12.04 LTS)
make CXXFLAGS='-std=c++11' ### gcc-4.8 (as in Ubuntu 14.04 LTS)
make CXXFLAGS='-std=c++11' LDFLAGS='-stdlib=libc++' ### OS X Mavericks
* Input and output files
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment