Commit e96a486b authored by VIGNET Pierre's avatar VIGNET Pierre
Browse files

Fix imports of concurrent futures in old release of Python 2.7

parent 6f93259c
......@@ -9,7 +9,11 @@ import os
from functools import partial
import sys
# Multiprocessing
from concurrent.futures import ProcessPoolExecutor, as_completed
try:
from concurrent.futures import ProcessPoolExecutor, as_completed
except ImportError:
raise ImportError("No module named concurrent.futures. \
You can try to install 'futures' module in Python 2.7")
import multiprocessing as mp
# Custom imports
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment