Commit 45a1c260 authored by VIGNET Pierre's avatar VIGNET Pierre
Browse files

Add python-tk system package dependency; more info on the usefulness of system packages

parent 045cd743
......@@ -13,13 +13,18 @@ CADBIOM is mainly developed in Python 2.7.
Before running Cadbiom, the following system packages have to be installed from
the distribution packages library (or similar, depending on your operating system):
* python-gtksourceview2
* python2.7-dev
* libxml2-dev
* libxslt1-dev
* libgraphviz-dev
* python-glade2
* python-gtk2
* libgraphviz-dev (Networkx layouts)
* pkg-config (Fix errors when installing pygraphviz and when config is not loaded)
* libpng12-dev (Matplotlib)
* libfreetype6-dev (Matplotlib)
* python-glade2 (GUI)
* python-gtk2 (GUI)
* python-gtksourceview2 (GUI)
* python-tk (GUI)
Fix errors when installing pygraphviz and when config is not loaded:
......@@ -30,11 +35,12 @@ For Matplotlib installation:
* libpng12-dev
* libfreetype6-dev
You can install these dependencies with the following command (on Debian systems):
You can install these dependencies with the following command (on Debian-like systems):
sudo apt-get install python-gtksourceview2 python2.7-dev libxml2-dev libxslt1-dev \
libxslt1-dev libgraphviz-dev pkg-config python-glade2 python-gtk2 libpng12-dev libfreetype6-dev
libxslt1-dev libgraphviz-dev pkg-config python-glade2 python-gtk2 python-tk libpng12-dev libfreetype6-dev
PS: Most of these packages are already installed on basic Debian-like systems.
## Python requirements
......@@ -88,7 +94,7 @@ The location of this script may vary depending on your Linux distro
Cadbiom software requires a SAT solver which is
proposed as a Python wrapper by an independant library (pycryptosat).
*For now, an non official version of pycryptosat is on pypi and it is used by packages;
*For now, an non official version of pycryptosat is on pypi and it is used by packages;
Source of the fork if you want to compile it manually:
[Cryptominisat repository](https://github.com/msoos/cryptominisat/tree/5.0.1)*
......
......@@ -13,13 +13,18 @@ CADBIOM is mainly developed in Python 2.7.
Before running Cadbiom, the following system packages have to be installed from
the distribution packages library (or similar, depending on your operating system):
* python-gtksourceview2
* python2.7-dev
* libxml2-dev
* libxslt1-dev
* libgraphviz-dev
* python-glade2
* python-gtk2
* libgraphviz-dev (Networkx layouts)
* pkg-config (Fix errors when installing pygraphviz and when config is not loaded)
* libpng12-dev (Matplotlib)
* libfreetype6-dev (Matplotlib)
* python-glade2 (GUI)
* python-gtk2 (GUI)
* python-gtksourceview2 (GUI)
* python-tk (GUI)
Fix errors when installing pygraphviz and when config is not loaded:
......@@ -30,11 +35,12 @@ For Matplotlib installation:
* libpng12-dev
* libfreetype6-dev
You can install these dependencies with the following command (on Debian systems):
You can install these dependencies with the following command (on Debian-like systems):
sudo apt-get install python-gtksourceview2 python2.7-dev libxml2-dev libxslt1-dev \
libxslt1-dev libgraphviz-dev pkg-config python-glade2 python-gtk2 libpng12-dev libfreetype6-dev
libxslt1-dev libgraphviz-dev pkg-config python-glade2 python-gtk2 python-tk libpng12-dev libfreetype6-dev
PS: Most of these packages are already installed on basic Debian-like systems.
## Python requirements
......@@ -88,7 +94,7 @@ The location of this script may vary depending on your Linux distro
Cadbiom software requires a SAT solver which is
proposed as a Python wrapper by an independant library (pycryptosat).
*For now, an non official version of pycryptosat is on pypi and it is used by packages;
*For now, an non official version of pycryptosat is on pypi and it is used by packages;
Source of the fork if you want to compile it manually:
[Cryptominisat repository](https://github.com/msoos/cryptominisat/tree/5.0.1)*
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment