Commit 7f30cc68 authored by Jussi Lindgren's avatar Jussi Lindgren

Build: Changed the Ubuntu version detection for 15.10

parent c326f8e5
......@@ -369,9 +369,10 @@ if [[ ! -e "$ov_target_folder_hit/no-native-packages.hit" ]]; then
if [[ "`grep -E 'Ubuntu|LinuxMint' /etc/lsb-release 2> /dev/null`" != "" || "`grep -E 'Raspbian' /etc/os-release 2> /dev/null`" != "" || "`grep Debian /etc/issue 2> /dev/null`" != "" ]]; then
ov_native_package_installed=true
ov_native_package_log_file="$ov_target_folder_log/native-packages.log"
if [[ "`grep -E '14.04|13.10|14.10' /etc/lsb-release 2> /dev/null`" != "" ]]; then
ov_ubuntu_version=`lsb_release -r -s 2>/dev/null`
if [[ `expr $ov_ubuntu_version \>= 13.10` == 1 ]]; then
# at the time of writing this, there was a conflict between libogre-dev and libboost-thread-dev dependencies in 13.10 and 14.04
echo " Ubuntu 13.10, 14.04 or 14.10 detected, suggesting specific set of packages..."
echo " Ubuntu $ov_ubuntu_version detected, suggesting specific set of packages..."
ov_lib_ogre_dev=libogre-1.8-dev
else
ov_lib_ogre_dev=libogre-dev
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment