Commit 9a1c6b99 authored by SOLIMAN Sylvain's avatar SOLIMAN Sylvain
Browse files

properly call pip from python3

parent 420d27d6
......@@ -119,22 +119,18 @@ fi
### Jupyter and python-sat
packages='python-sat jupyter bokeh ipywidgets'
if hash pip3 2>/dev/null
if (hash pip3 2>/dev/null) || \
(hash pip 2> /dev/null) && [[ "pip --version" = "*python 3*" ]]
then
pip3 install -U $packages
elif (hash pip 2> /dev/null) && [[ "pip --version" = "*python 3*" ]]
then
pip install -U $packages
python3 -m pip install -U $packages
else
if hash conda 2>/dev/null
then
conda install -y pip
pip install -U $packages
else
if [[ "$conda_arch" == "Linux" ]]
then
sudo apt-get -qy install python3-pip
pip install -U $packages
else
# Note that miniconda is available through brew cask, but to avoid adding
# brew cask if not necessary, we just do without
......@@ -144,9 +140,9 @@ else
echo 'export PATH=${HOME}/miniconda3/bin:${PATH}' >> ${HOME}/.profile
export PATH=${HOME}/miniconda3/bin:${PATH}
conda install -y pip
pip install -U $packages
fi
fi
python3 -m pip install -U $packages
fi
### trust all our notebooks but make them read-only
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment