Commit 7b63a4d3 authored by Gérard Huet's avatar Gérard Huet

Makefile fix

parent c9aff367
...@@ -80,10 +80,10 @@ padapatha.cmx sanskrit.cmx order.cmx ...@@ -80,10 +80,10 @@ padapatha.cmx sanskrit.cmx order.cmx
ANNOTFLAGS = -annot -bin-annot ANNOTFLAGS = -annot -bin-annot
COMPILE=ocamlopt -pp "camlp4r pa_extend.cmo" -I $(ZEN) -I +camlp4 -c \ COMPILE=ocamlopt -pp "camlp4rf" -I $(ZEN) -I +camlp4 -c \
$(ANNOTFLAGS) $(ANNOTFLAGS)
COMPILEI=ocamlc -pp "camlp4r pa_extend.cmo" -I $(ZEN) -I +camlp4 -c \ COMPILEI=ocamlc -pp "camlp4rf" -I $(ZEN) -I +camlp4 -c \
$(ANNOTFLAGS) $(ANNOTFLAGS)
LINK=ocamlopt -I $(ZEN) -I +camlp4 dynlink.cmxa camlp4lib.cmxa LINK=ocamlopt -I $(ZEN) -I +camlp4 dynlink.cmxa camlp4lib.cmxa
......
...@@ -27,13 +27,13 @@ Then install package Ocamlbuild from https://github.com/ocaml/ocamlbuild/release ...@@ -27,13 +27,13 @@ Then install package Ocamlbuild from https://github.com/ocaml/ocamlbuild/release
for instance OCamlbuild 0.12.0: for instance OCamlbuild 0.12.0:
make configure make configure
make make
make install sudo make install
Then install Camlp4 from GitHub, in the 4.07 branch, available from Then install Camlp4 from GitHub, in the 4.07 branch, available from
https://github.com/ocaml/camlp4/releases; take for instance 4.07+1. https://github.com/ocaml/camlp4/releases; take for instance 4.07+1.
This should be installed by: This should be installed by:
./configure ./configure
make all make all # beware: not just make
sudo make install sudo make install
The following instructions assume installation under some version of the The following instructions assume installation under some version of the
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment