Commit 3b849edd authored by Ludovic Courtès's avatar Ludovic Courtès
Browse files

cuda: Default to 11.0.

* non-free/cuda.scm (cuda): Change to CUDA-11.0.
* inria/tainted/storm.scm (starpu+cuda)[native-inputs]: Remove
NO-FLOAT128.
[build-system]: Remove.
parent ecffef86
......@@ -67,12 +67,8 @@ implicit GCC."
(package
(inherit starpu)
(name "starpu-cuda")
;; "host_config.h" in 'cuda-toolkit' says "gcc versions later than 5 are
;; not supported". Thus, provide GCC 5.x.
(build-system (gnu-build-system-with-compiler gcc-5))
(native-inputs
`(("no-float128" ,no-float128)
("gfortran" ,gfortran-sans-libstdc++)
`(("gfortran" ,gfortran-sans-libstdc++)
,@(alist-delete "gfortran" (package-native-inputs starpu))))
(inputs
`(("cuda" ,cuda)
......
......@@ -210,7 +210,7 @@ libraries for NVIDIA GPUs, all of which are proprietary.")
(define-public cuda
;; Default version.
cuda-8.0)
cuda-11.0)
(define-public no-float128
;; FIXME: We cannot simply add it to 'propagated-inputs' of cuda-toolkit
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment