Commit 4d430338 authored by MARGERY David's avatar MARGERY David
Browse files

fixup! [Bug #9792] Update and use build dependencies

parent 49cd75be
Pipeline #46952 failed with stages
in 1 minute and 41 seconds
...@@ -59,7 +59,7 @@ deb-for-jessie: &deb-for-jessie ...@@ -59,7 +59,7 @@ deb-for-jessie: &deb-for-jessie
- apt-get update && apt-get -y --no-install-recommends install devscripts build-essential equivs - apt-get update && apt-get -y --no-install-recommends install devscripts build-essential equivs
- "sed -i -e 's/default-libmysqlclient-dev/libmysqlclient-dev/' debian/control" - "sed -i -e 's/default-libmysqlclient-dev/libmysqlclient-dev/' debian/control"
- mk-build-deps -ir -t 'apt-get -y --no-install-recommends' - mk-build-deps -ir -t 'apt-get -y --no-install-recommends'
- apt-get install -y lsb-release curl pkg-config - apt-get install -y curl pkg-config
- bundle install --path vendor/bundle - bundle install --path vendor/bundle
- bundle exec rake package:build:debian - bundle exec rake package:build:debian
artifacts: artifacts:
...@@ -75,7 +75,7 @@ deb-for-stretch: ...@@ -75,7 +75,7 @@ deb-for-stretch:
script: script:
- apt-get update && apt-get -y --no-install-recommends install devscripts build-essential equivs - apt-get update && apt-get -y --no-install-recommends install devscripts build-essential equivs
- mk-build-deps -ir -t 'apt-get -y --no-install-recommends' - mk-build-deps -ir -t 'apt-get -y --no-install-recommends'
- apt-get install -y lsb-release curl pkg-config - apt-get install -y curl pkg-config
- bundle install --path vendor/bundle - bundle install --path vendor/bundle
- bundle exec rake package:build:debian - bundle exec rake package:build:debian
......
...@@ -3,7 +3,7 @@ Section: unknown ...@@ -3,7 +3,7 @@ Section: unknown
Priority: extra Priority: extra
Maintainer: Grid'5000 developpers <g5k-developers@lists.grid5000.fr> Maintainer: Grid'5000 developpers <g5k-developers@lists.grid5000.fr>
Uploaders: David Margery <david.margery@inria.fr> Uploaders: David Margery <david.margery@inria.fr>
Build-Depends: debhelper (>= 7), git, bundler, rake, libssl-dev, libxml2-dev, libxslt-dev, libicu-dev, default-libmysqlclient-dev, libpq-dev, nodejs, ruby-dev Build-Depends: debhelper (>= 7), git, bundler, rake, libssl-dev, libxml2-dev, libxslt-dev, libicu-dev, default-libmysqlclient-dev, libpq-dev, nodejs, ruby-dev, lsb_release
Standards-Version: 3.7.3 Standards-Version: 3.7.3
Homepage: https://api.grid5000.fr Homepage: https://api.grid5000.fr
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment