Commit 931e51f4 authored by Baptiste Jonglez's avatar Baptiste Jonglez

[big] [prometheus] Force version of datacenter-gpu-manager

dcgm-exporter links against datacenter-gpu-manager 1.X, so it does not
find the .so file of datacenter-gpu-manager 2.X.  Force version 1.X.
parent 588e8765
......@@ -5,8 +5,14 @@ class env::big::configure_nvidia_gpu::prometheus () {
env::common::g5kpackages {
'nvidia-dcgm-exporter':
packages => ['dcgm-exporter', 'datacenter-gpu-manager'],
ensure => installed;
packages => 'dcgm-exporter';
}
# Version 2.X bumped the SONAME, so we force version 1.X for now
package {
'datacenter-gpu-manager':
ensure => $::env::common::software_versions::datacenter_gpu_manager,
require => Env::Common::G5kpackages['nvidia-dcgm-exporter'];
}
file{
......
......@@ -10,4 +10,5 @@ class env::common::software_versions {
$libguestfs_backport_arm64 = '1:1.40.2-7~bpog5k10+1'
$libguestfs_backport_ppc64el = '1:1.40.2-7~bpog5k10+1'
$lmod = '6.6-0.3g5k1'
$datacenter_gpu_manager = '1.7.2'
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment