diff --git a/debian/rules b/debian/rules
index 237168bfce6c12e681654696755ab5e77312a327..1cf04d9212923c9ea544e781f0fc45ac548e5838 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,7 +20,6 @@ DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 
 # Configura package and enable dependencies available on all platforms.
-# dc1394: off (obsolete)
 # libav (ffmpeg): available on all platforms
 # opencv: available on all platforms
 # coin3: available on all platforms
@@ -35,7 +34,7 @@ CONFIGURE_ARGS=	\
  -DCMAKE_INSTALL_LIBDIR:STRING="lib/$(DEB_HOST_MULTIARCH)"	\
  -DBUILD_DEMOS=ON -DBUILD_TESTING=ON -DBUILD_EXAMPLES=ON	\
  -DBUILD_SHARED_LIBS=ON						\
- -DUSE_DC1394_1=OFF -DUSE_FFMPEG=ON				\
+ -DUSE_FFMPEG=ON						\
  -DUSE_OPENCV=ON 						\
  -DUSE_COIN=ON -DUSE_GSL=OFF					\
  -DUSE_LAPACK=ON -DUSE_GSL=ON -DUSE_OGRE=ON			\
@@ -44,11 +43,11 @@ CONFIGURE_ARGS=	\
 
 # dc1394, v4l and ois are only available on Linux.
 ifneq ($(DEB_HOST_ARCH_OS),linux)
-  CONFIGURE_ARGS += -DUSE_DC1394_2=OFF -DUSE_V4L2:BOOL=OFF -DUSE_OIS=OFF
+  CONFIGURE_ARGS += -DUSE_DC1394=OFF -DUSE_V4L2=OFF -DUSE_OIS=OFF
 # OGRE support triggers ICE on FreeBSD, disable for now.
   CONFIGURE_ARGS += -DUSE_OGRE=OFF
 else
-  CONFIGURE_ARGS += -DUSE_DC1394_2=ON -DUSE_V4L2:BOOL=ON -DUSE_OIS=ON
+  CONFIGURE_ARGS += -DUSE_DC1394=ON -DUSE_V4L2=ON -DUSE_OIS=ON
 endif
 
 # freenect is not available on hurd.