From cc416c7f5a89467adbdb254e3b13f34d26b4c09e Mon Sep 17 00:00:00 2001
From: Thomas Moulard <thomas.moulard@gmail.com>
Date: Thu, 26 Sep 2013 13:05:15 +0900
Subject: [PATCH] Fix debian/rules

Git-Dch: ignore
---
 debian/rules | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/debian/rules b/debian/rules
index 53850a30..370e63f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -87,11 +87,12 @@ override_dh_strip:
 # This is not a critical issue so we let the testing fail on this
 # architecture for now.
 # See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=723803
-override_dh_auto_test:
 ifeq ($(DEB_HOST_ARCH),ia64)
-	export VISP_INPUT_IMAGE_PATH=/usr/share/visp-images-data/ \
-	 && dh_auto_test --max-parallel=1 || true
+DH_AUTOTEST_CAN_FAIL=true
 else
+DH_AUTOTEST_CAN_FAIL=false
+endif
+
+override_dh_auto_test:
 	export VISP_INPUT_IMAGE_PATH=/usr/share/visp-images-data/ \
-	 && dh_auto_test --max-parallel=1
-fi
+	 && dh_auto_test --max-parallel=1 || ${DH_AUTOTEST_CAN_FAIL}
-- 
GitLab