diff --git a/debian/changelog b/debian/changelog
index 9c09a58ee0b9398da90325600bcaf7ec395267e8..8bcac22e1b171a7b96bed1a8d56027cde1bc44f4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,7 +3,7 @@ visp (2.6.2-1) unstable; urgency=low
   * Import new upstream version 2.6.2 (Closes: #691252).
   * Add patch to rename libvisp-2.so into libvisp.so.
   * Add patch to support multiarch (avoid making the assumption that
-	$prefix/lib is the library directory but use $libdir instead).
+    $prefix/lib is the library directory but use $libdir instead).
   * Add patch that fix typos in source code.
   * Provide visp-config man page.
 
diff --git a/debian/control b/debian/control
index 1c584f7d3cb0fb9ec647b5c5baeef5badc3d0e79..d8d856264c098f144ff472b4f414c63f0d3c6fa1 100644
--- a/debian/control
+++ b/debian/control
@@ -55,6 +55,7 @@ Depends: libopencv-dev,
 	 libfreenect-dev (>= 0.0.1),
 	 libois-dev,
 	 ${misc:Depends}
+Suggests: libvisp-doc
 Description: visual servoing library - development files
  ViSP, standing for Visual Servoing Platform, is unique. This software
  is a complete cross-platform solution that allows prototyping and
@@ -92,3 +93,17 @@ Description: visual servoing library - debugging symbols
  computer animation.
  .
  This package contains the debugging symbols for the shared libraries.
+
+Package: libvisp-doc
+Architecture: all
+Section: doc
+Depends: ${misc:Depends}
+Description: visual servoing library - documentation
+ ViSP, standing for Visual Servoing Platform, is unique. This software
+ is a complete cross-platform solution that allows prototyping and
+ developing applications in visual tracking and visual servoing.
+ .
+ ViSP can be useful in robotics, computer vision, augmented reality and
+ computer animation.
+ .
+ This package contains the Doxygen generated documentation.
diff --git a/debian/libvisp-doc.doc-base b/debian/libvisp-doc.doc-base
new file mode 100644
index 0000000000000000000000000000000000000000..4d8e2a893348b7e76884c004889ac5f76101bd1c
--- /dev/null
+++ b/debian/libvisp-doc.doc-base
@@ -0,0 +1,9 @@
+Document: visp
+Title: ViSP C++ API reference
+Author: INRIA Bretagne, LAGADIC
+Abstract: Describe the ViSP library C++ API.
+Section: Programming/C++
+
+Format: HTML
+Index: /usr/share/doc/libvisp-doc/html/index.html
+Files: /usr/share/doc/libvisp-doc/html/*
diff --git a/debian/libvisp-doc.docs b/debian/libvisp-doc.docs
new file mode 100644
index 0000000000000000000000000000000000000000..395f4e3f8fa4783786875cc222f3f385c868ed9b
--- /dev/null
+++ b/debian/libvisp-doc.docs
@@ -0,0 +1 @@
+*/doc/html/
diff --git a/debian/rules b/debian/rules
index a2a13ce2e13275874ffdf61dbca1098c2cddebeb..10333ab7b2a21cfd52f6b352ad4e4ef87c7efb30 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,9 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
-# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
-
-.PHONY: override_dh_auto_configure override_dh_strip override_dh_auto_test
+.PHONY: override_dh_auto_configure	\
+	override_dh_auto_build		\
+	override_dh_strip		\
+	override_dh_auto_test
 
 %:
 	dh  $@
@@ -22,17 +16,20 @@ override_dh_auto_clean:
 override_dh_auto_configure:
 	dh_auto_configure -- \
 		-DBUILD_DEMOS=ON -DBUILD_TESTING=ON -DBUILD_EXAMPLES=ON \
-		-DBUILD_SHARED_LIBS=ON -DBUILD_DEPRECATED=ON		\
+		-DBUILD_SHARED_LIBS=ON					\
 		-DUSE_DC1394_1=OFF -DUSE_FFMPEG=ON			\
 		-DUSE_DC1394_2=ON -DUSE_V4L2=ON -DUSE_OPENCV=ON 	\
 		-DUSE_COIN=ON -DUSE_GSL=OFF				\
 		-DUSE_LAPACK=ON -DUSE_OGRE=ON				\
 		-DUSE_XML2=ON -DUSE_GTK2=ON -DUSE_LIBJPEG=ON		\
-		-DUSE_LIBPNG=ON -DUSE_LIBPLOTTER=ON			\
+		-DUSE_LIBPNG=ON						\
 		-DUSE_LIBFREENECT=ON -DUSE_X11=ON -DUSE_OIS=ON		\
-		-DDESIRED_QT_VERSION=4					\
 		-DCMAKE_INSTALL_LIBDIR:STRING="lib/$(DEB_HOST_MULTIARCH)"
 
+override_dh_auto_build:
+	dh_auto_build -- # Compile the software.
+	dh_auto_build -- html-doc # Generate Doxygen HTML documentation.
+
 override_dh_strip:
 	dh_strip -a --dbg-package=libvisp-dbg