From 93ab988406437fb318ad50ec0e246719522f0447 Mon Sep 17 00:00:00 2001
From: Fabien Spindler <Fabien.Spindler@inria.fr>
Date: Tue, 20 Apr 2021 15:10:54 +0200
Subject: [PATCH] Disable parallel build on armel

---
 debian/rules | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/debian/rules b/debian/rules
index 27479082..67c6b9e4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,6 +15,13 @@ else
   CMAKE_ARCH_FLAGS = -DUSE_DC1394=OFF -DUSE_V4L2=OFF -DUSE_OIS=OFF
 endif
 
+# On armel, since 3.4.0-3 build returns the following error
+# "ABORT: Received TERM signal"
+# Disable parallel build (make -j1) to reduce memory usage
+ifeq ($(DEB_HOST_ARCH_OS),armel)
+  export DEB_BUILD_OPTIONS="parallel=1"
+endif
+
 # CMake flags
 CMAKE_FLAGS = \
 	-DCMAKE_INSTALL_PREFIX=/usr \
-- 
GitLab