diff --git a/debian/patches/0001-Replace-visp-2-by-visp-in-CMakeLists.txt.patch b/debian/patches/0001-Replace-visp-2-by-visp-in-CMakeLists.txt.patch
deleted file mode 100644
index abd8931cbd5660874abb198af61cce119f3651cb..0000000000000000000000000000000000000000
--- a/debian/patches/0001-Replace-visp-2-by-visp-in-CMakeLists.txt.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Thomas Moulard <thomas.moulard@gmail.com>
-Date: Tue, 4 Dec 2012 13:20:27 +0900
-Subject: Replace "visp-2" by "visp" in CMakeLists.txt
-
-Remove redundant information as ABI version is already provided
-by library suffix (libvisp-2.so.2).
-
-Forwarded: https://gforge.inria.fr/tracker/index.php?func=detail&aid=15221&group_id=397&atid=1660
-Author: Thomas Moulard <thomas.moulard@gmail.com>
----
- CMakeLists.txt |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 92fd6d6..9c58784 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -64,7 +64,7 @@ SET(VISP_INTERN_INCLUDE_DIR ${VISP_BINARY_DIR}/include)
- # the third party include directories we depend on
- SET(VISP_EXTERN_INCLUDE_DIRS "")
- # the internal visp libs we depend on
--SET(VISP_INTERN_LIBRARY visp-2)
-+SET(VISP_INTERN_LIBRARY visp)
- # the third party libraries we depend on
- SET(VISP_EXTERN_LIBRARIES "")
- # the compiler definitions
diff --git a/debian/patches/0002-Fix-library-location-in-the-buildchain-for-multiarch.patch b/debian/patches/0002-Fix-library-location-in-the-buildchain-for-multiarch.patch
deleted file mode 100644
index 9b3d7bf72902e450ccc567d246d8fa3147320652..0000000000000000000000000000000000000000
--- a/debian/patches/0002-Fix-library-location-in-the-buildchain-for-multiarch.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From: Thomas Moulard <thomas.moulard@gmail.com>
-Date: Thu, 20 Dec 2012 10:02:10 +0900
-Subject: Fix library location in the buildchain for multiarch support.
-
-visp-config makes the false assumption libs are installed
-in $prefix/lib. The VISPConfig.cmake.in file used to detect ViSP
-through CMake has the same issue. Fix both.
-
-Forwarded: https://gforge.inria.fr/tracker/index.php?func=detail&aid=15221&group_id=397&atid=1660
-Author: Thomas Moulard <thomas.moulard@gmail.com>
----
- CMakeModules/GenerateConfigScript.cmake |    4 ++--
- CMakeModules/VISPConfig.cmake.in        |    3 ++-
- 2 files changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeModules/GenerateConfigScript.cmake b/CMakeModules/GenerateConfigScript.cmake
-index 2bd41a9..42894d8 100644
---- a/CMakeModules/GenerateConfigScript.cmake
-+++ b/CMakeModules/GenerateConfigScript.cmake
-@@ -144,10 +144,10 @@ IF (UNIX)
-   #MESSAGE("EXTERN LIBS : ${VISP_CONFIG_SCRIPT_EXTERN_LIBS}")
-  
-   # prepend with ViSP own lib dir
--  SET(VISP_CONFIG_SCRIPT_EXTERN_LIBS  "-L$PREFIX/lib -l${VISP_INTERN_LIBRARY} ${VISP_CONFIG_SCRIPT_EXTERN_LIBS}")
-+  SET(VISP_CONFIG_SCRIPT_EXTERN_LIBS  "-L${CMAKE_INSTALL_FULL_LIBDIR} -l${VISP_INTERN_LIBRARY} ${VISP_CONFIG_SCRIPT_EXTERN_LIBS}")
-   IF(UNIX)
-     IF(NOT APPLE)
--      SET(VISP_CONFIG_SCRIPT_EXTERN_LIBS  "-Wl,-rpath,$PREFIX/lib ${VISP_CONFIG_SCRIPT_EXTERN_LIBS}")
-+      SET(VISP_CONFIG_SCRIPT_EXTERN_LIBS  "-Wl,-rpath,${CMAKE_INSTALL_FULL_LIBDIR} ${VISP_CONFIG_SCRIPT_EXTERN_LIBS}")
-     ENDIF(NOT APPLE)
-   ENDIF(UNIX)
- 
-diff --git a/CMakeModules/VISPConfig.cmake.in b/CMakeModules/VISPConfig.cmake.in
-index 4f84c1e..7865188 100644
---- a/CMakeModules/VISPConfig.cmake.in
-+++ b/CMakeModules/VISPConfig.cmake.in
-@@ -92,7 +92,8 @@ ENDFOREACH(val ${VISP_EXTERN_INCLUDE_DIRS})
- #MESSAGE("VISP_INCLUDE_DIRS: ${VISP_INCLUDE_DIRS}")
- 
- # Tells the user project where to find ViSP library
--SET(VISP_LIBRARY_DIRS "${VISP_ROOT_DIR}/lib" CACHE FILEPATH "Location of ViSP library")
-+SET(VISP_LIBRARY_DIRS "${CMAKE_INSTALL_FULL_LIBDIR}"
-+  CACHE FILEPATH "Location of ViSP library")
- 
- # Tells the user project where to find third party libraries used to
- # compile ViSP
diff --git a/debian/patches/0003-Fix-typos-in-source-code.patch b/debian/patches/0003-Fix-typos-in-source-code.patch
deleted file mode 100644
index fa4ac6455c46c67380ca90e415ee6fc9f63d6fef..0000000000000000000000000000000000000000
--- a/debian/patches/0003-Fix-typos-in-source-code.patch
+++ /dev/null
@@ -1,221 +0,0 @@
-From: Thomas Moulard <thomas.moulard@gmail.com>
-Date: Thu, 20 Dec 2012 11:22:34 +0900
-Subject: Fix typos in source code.
-
-Forwarded: https://gforge.inria.fr/tracker/index.php?func=detail&aid=15221&group_id=397&atid=1660
-Author: Thomas Moulard <thomas.moulard@gmail.com>
----
- src/computer-vision/pose-estimation/vpPose.cpp     |    2 +-
- src/device/framegrabber/v4l2/vpV4l2Grabber.h       |    2 +-
- src/servo/vpServo.cpp                              |    2 +-
- .../wireframe-simulator/vpWireFrameSimulator.h     |    2 +-
- src/tracking/mbt/vpMbTracker.h                     |    2 +-
- src/tracking/mbt/vpMbtXmlParser.cpp                |   38 ++++++++++----------
- 6 files changed, 24 insertions(+), 24 deletions(-)
-
-diff --git a/src/computer-vision/pose-estimation/vpPose.cpp b/src/computer-vision/pose-estimation/vpPose.cpp
-index 46342f2..cf3c5f5 100644
---- a/src/computer-vision/pose-estimation/vpPose.cpp
-+++ b/src/computer-vision/pose-estimation/vpPose.cpp
-@@ -141,7 +141,7 @@ vpPose::clearPoint()
- \brief  Add a new point in the array of point.
- \param  newP : New point to add  in the array of point.
- \warning Considering a point from the class vpPoint, X, Y, and Z will
--represent the 3D information and x and y its 2D informations.
-+represent the 3D information and x and y its 2D information.
- These 5 fields must be initialized to be used within this library
- */
- void
-diff --git a/src/device/framegrabber/v4l2/vpV4l2Grabber.h b/src/device/framegrabber/v4l2/vpV4l2Grabber.h
-index 29d524c..1e571c4 100644
---- a/src/device/framegrabber/v4l2/vpV4l2Grabber.h
-+++ b/src/device/framegrabber/v4l2/vpV4l2Grabber.h
-@@ -222,7 +222,7 @@ public:
-     return (this->pixelformat);
-   }
-   /*!
--    Activates the verbose mode to print additionnal informations on stdout.
-+    Activates the verbose mode to print additional information on stdout.
-     \param verbose : If true activates the verbose mode.
-   */
-   void setVerboseMode(bool verbose) {
-diff --git a/src/servo/vpServo.cpp b/src/servo/vpServo.cpp
-index c6d01c1..6a9d50a 100644
---- a/src/servo/vpServo.cpp
-+++ b/src/servo/vpServo.cpp
-@@ -239,7 +239,7 @@ void
- 
- /*!
- 
--  Prints on \e os stream informations about the task:
-+  Prints on \e os stream information about the task:
- 
-   \param displayLevel : If vpServo::ALL prints
-   - Type of control law (eye-in-hand, eye-to-hand)
-diff --git a/src/simulator/wireframe-simulator/vpWireFrameSimulator.h b/src/simulator/wireframe-simulator/vpWireFrameSimulator.h
-index d494d44..a8c05c6 100644
---- a/src/simulator/wireframe-simulator/vpWireFrameSimulator.h
-+++ b/src/simulator/wireframe-simulator/vpWireFrameSimulator.h
-@@ -132,7 +132,7 @@ void vp2jlc_matrix (const vpHomogeneousMatrix, Matrix&);
-   
-   - cextMf which is the displacement between one external camera frame and the world frame.
-   
--  The following picture summarize all the previous informations.
-+  The following picture summarize all the previous information.
-   
-   \image html vpWireFrameSimulator.jpeg
-   \image latex vpWireFrameSimulator.ps
-diff --git a/src/tracking/mbt/vpMbTracker.h b/src/tracking/mbt/vpMbTracker.h
-index 71539cf..759acd9 100755
---- a/src/tracking/mbt/vpMbTracker.h
-+++ b/src/tracking/mbt/vpMbTracker.h
-@@ -83,7 +83,7 @@
-   - track() : Tracking on the current image
-   - testTracking() : Test the tracking. This method throws exception if the 
-     tracking failed. 
--  - display() : Display the model and eventually other informations.
-+  - display() : Display the model and eventually other information.
- 
-   In addition, two flags are declared in this class and may have to be 
-   initialised in the child class : 
-diff --git a/src/tracking/mbt/vpMbtXmlParser.cpp b/src/tracking/mbt/vpMbtXmlParser.cpp
-index 917716e..179e271 100644
---- a/src/tracking/mbt/vpMbtXmlParser.cpp
-+++ b/src/tracking/mbt/vpMbtXmlParser.cpp
-@@ -166,18 +166,18 @@ vpMbtXmlParser::readMainClass(xmlDocPtr doc, xmlNodePtr node)
-   if(nb != 3){
- 		std::cout <<"ERROR in 'ECM' field:\n";
- 		std::cout << "it must contain 3 parameters\n";
--    throw vpException(vpException::fatalError, "Bad number of data to extract ECM informations.");
-+    throw vpException(vpException::fatalError, "Bad number of data to extract ECM information.");
- 	}
- }
- 
- 
- /*!
--  Read ecm informations.
-+  Read ecm information.
-   
-   \throw vpException::fatalError if there was an unexpected number of data. 
-   
-   \param doc : Pointer to the document.
--  \param node : Pointer to the node of the ecm informations.
-+  \param node : Pointer to the node of the ecm information.
- */
- void 
- vpMbtXmlParser::lecture_ecm (xmlDocPtr doc, xmlNodePtr node)
-@@ -212,17 +212,17 @@ vpMbtXmlParser::lecture_ecm (xmlDocPtr doc, xmlNodePtr node)
-   if(nb != 3){
- 		std::cout <<"ERROR in 'ECM' field:\n";
- 		std::cout << "it must contain 3 parameters\n";
--    throw vpException(vpException::fatalError, "Bad number of data to extract ECM informations.");
-+    throw vpException(vpException::fatalError, "Bad number of data to extract ECM information.");
- 	}
- }
- 
- /*!
--  Read sample informations.
-+  Read sample information.
-   
-   \throw vpException::fatalError if there was an unexpected number of data. 
-   
-   \param doc : Pointer to the document.
--  \param node : Pointer to the node of the sample informations.
-+  \param node : Pointer to the node of the sample information.
- */
- void 
- vpMbtXmlParser::lecture_sample (xmlDocPtr doc, xmlNodePtr node)
-@@ -264,17 +264,17 @@ vpMbtXmlParser::lecture_sample (xmlDocPtr doc, xmlNodePtr node)
- 	else{
- 		std::cout <<"ERROR in 'sample' field:\n";
- 		std::cout << "it must contain 2 parameters\n";
--    throw vpException(vpException::fatalError, "Bad number of data to extract sample informations.");
-+    throw vpException(vpException::fatalError, "Bad number of data to extract sample information.");
- 	}
- }
- 
- /*!
--  Read camera informations.
-+  Read camera information.
-   
-   \throw vpException::fatalError if there was an unexpected number of data. 
-   
-   \param doc : Pointer to the document.
--  \param node : Pointer to the node of the camera informations.
-+  \param node : Pointer to the node of the camera information.
- */
- void 
- vpMbtXmlParser::lecture_camera (xmlDocPtr doc, xmlNodePtr node)
-@@ -337,17 +337,17 @@ vpMbtXmlParser::lecture_camera (xmlDocPtr doc, xmlNodePtr node)
- 	else{
- 		std::cout <<"ERROR in 'camera' field:\n";
- 		std::cout << "it must contain  6 parameters\n";
--    throw vpException(vpException::fatalError, "Bad number of data to extract camera informations.");
-+    throw vpException(vpException::fatalError, "Bad number of data to extract camera information.");
- 	}
- }
- 
- /*!
--  Read mask informations for the vpMeSite.
-+  Read mask information for the vpMeSite.
-   
-   \throw vpException::fatalError if there was an unexpected number of data. 
-   
-   \param doc : Pointer to the document.
--  \param node : Pointer to the node of the mask informations.
-+  \param node : Pointer to the node of the mask information.
- */
- void 
- vpMbtXmlParser::lecture_mask (xmlDocPtr doc, xmlNodePtr node)
-@@ -389,17 +389,17 @@ vpMbtXmlParser::lecture_mask (xmlDocPtr doc, xmlNodePtr node)
- 	else{
- 		std::cout <<"ERROR in 'mask' field:\n";
- 		std::cout << "it must contain  2 parameters\n";
--    throw vpException(vpException::fatalError, "Bad number of data to extract mask informations.");
-+    throw vpException(vpException::fatalError, "Bad number of data to extract mask information.");
- 	}
- }
- 
- /*!
--  Read range informations for the vpMeSite.
-+  Read range information for the vpMeSite.
-   
-   \throw vpException::fatalError if there was an unexpected number of data. 
-   
-   \param doc : Pointer to the document.
--  \param node : Pointer to the node of the range informations.
-+  \param node : Pointer to the node of the range information.
- */
- void 
- vpMbtXmlParser::lecture_range (xmlDocPtr doc, xmlNodePtr node)
-@@ -433,18 +433,18 @@ vpMbtXmlParser::lecture_range (xmlDocPtr doc, xmlNodePtr node)
- 	else{
- 		std::cout <<"ERROR in 'range' field:\n";
- 		std::cout << "it must contain  1 parameters\n";
--    throw vpException(vpException::fatalError, "Bad number of data to extract range informations.");
-+    throw vpException(vpException::fatalError, "Bad number of data to extract range information.");
- 	}
- }
- 
- 
- /*!
--  Read the contrast informations from the xml file.
-+  Read the contrast information from the xml file.
-   
-   \throw vpException::fatalError if there was an unexpected number of data. 
-   
-   \param doc : Pointer to the document.
--  \param node : Pointer to the node of the contrast informations.
-+  \param node : Pointer to the node of the contrast information.
- */
- void
- vpMbtXmlParser::lecture_contrast (xmlDocPtr doc, xmlNodePtr node)
-@@ -493,7 +493,7 @@ vpMbtXmlParser::lecture_contrast (xmlDocPtr doc, xmlNodePtr node)
- 	else{
- 		std::cout <<"ERROR in 'contrast' field:\n";
- 		std::cout << "it must contain  3 parameters\n";
--    throw vpException(vpException::fatalError, "Bad number of data to extract contrast informations.");
-+    throw vpException(vpException::fatalError, "Bad number of data to extract contrast information.");
- 	}
- }
- 
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 69607e0a7e54ccdbb5f97b90ea6c8a80c73ab527..0000000000000000000000000000000000000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,3 +0,0 @@
-0001-Replace-visp-2-by-visp-in-CMakeLists.txt.patch
-0002-Fix-library-location-in-the-buildchain-for-multiarch.patch
-0003-Fix-typos-in-source-code.patch