diff --git a/debian/rules b/debian/rules
index f91b1d592c9986f0b43b697e20ca9092b2da50e3..34b04b454936d602066591d5fadef34dee834a2a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,9 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
 
+# Test suite fails for this release.
+export DEB_BUILD_OPTIONS=nocheck
+
 # Hardening flags.
 export DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie
 
@@ -56,9 +59,8 @@ endif
 
 
 .PHONY: override_dh_auto_configure	\
-	override_dh_auto_build		\
-	override_dh_strip		\
-	override_dh_auto_test
+	override_dh_auto_build-indep	\
+	override_dh_strip
 
 %:
 	dh  $@ --parallel --with pkgkde-symbolshelper
@@ -71,11 +73,8 @@ override_dh_auto_clean:
 override_dh_auto_configure:
 	dh_auto_configure -- $(CONFIGURE_ARGS)
 
-override_dh_auto_build:
-	dh_auto_build -- # Compile the software.
+override_dh_auto_build-indep:
 	dh_auto_build -- html-doc # Generate Doxygen HTML documentation.
 
 override_dh_strip:
 	dh_strip -a --dbg-package=libvisp2-dbg
-
-override_dh_auto_test: