diff --git a/debian/control b/debian/control
index 4302aa33dafe2f17c06cf9888cd2dbfc480dfcfc..4c652c6248aa5f8b3b80319237c26d14c330a819 100644
--- a/debian/control
+++ b/debian/control
@@ -9,6 +9,7 @@ Build-Depends: debhelper (>= 9),
                doxygen-latex,
                libopencv-dev [!any-sparc64 !x32],
                liblapack-dev,
+               libgsl0-dev,
                libcoin80-dev | libcoin60-dev,
                libsoqt4-dev,
                libogre-1.9-dev [!any-sh4] | libogre-1.8-dev [!any-sh4] | libogre-dev [!any-sh4],
@@ -39,6 +40,7 @@ Architecture: any
 Section: libdevel
 Depends: libopencv-dev [!any-sparc64 !x32],
          liblapack-dev,
+         libgsl0-dev,
          libcoin80-dev | libcoin60-dev,
          libsoqt4-dev,
          libogre-1.9-dev [!any-sh4] | libogre-1.8-dev [!any-sh4] | libogre-dev [!any-sh4],
diff --git a/debian/rules b/debian/rules
index 6391887e71cd9b619a958b2b2983fd6943ab2fd1..237168bfce6c12e681654696755ab5e77312a327 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,6 +25,7 @@ DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 # opencv: available on all platforms
 # coin3: available on all platforms
 # lapack: available on all platforms
+# libgsl0: available on all platforms
 # ogre: available on all platforms
 # xml2: available on all platforms
 # libjpeg6b: available on all platforms
@@ -37,7 +38,7 @@ CONFIGURE_ARGS=	\
  -DUSE_DC1394_1=OFF -DUSE_FFMPEG=ON				\
  -DUSE_OPENCV=ON 						\
  -DUSE_COIN=ON -DUSE_GSL=OFF					\
- -DUSE_LAPACK=ON -DUSE_OGRE=ON					\
+ -DUSE_LAPACK=ON -DUSE_GSL=ON -DUSE_OGRE=ON			\
  -DUSE_XML2=ON -DUSE_GTK2=ON -DUSE_LIBJPEG=ON			\
  -DUSE_LIBPNG=ON -DUSE_X11=ON