Commit 7d28b4ed authored by POTTIER Francois's avatar POTTIER Francois

Revert "Interpret [checkOCamlVersion.ml] on the fly, instead of compiling it."

This should fix a problem encountered on (some versions of?) Windows,
where dynamic linking is not supported, hence #load fails.

This reverts commit 397d02c98b57f7e22925473871cf0e51ff031430.
parent ba3e052d
......@@ -44,7 +44,8 @@ bootstrap: .versioncheck stage1 stage2 stage3
.versioncheck:
@ echo Checking that OCaml is recent enough...
@ ocaml checkOCamlVersion.ml --verbose --gt "4.02"
@$(OCAMLBUILD) -build-dir _stage1 checkOCamlVersion.byte
@ _stage1/checkOCamlVersion.byte --verbose --gt "4.02"
@ touch $@
# ----------------------------------------------------------------------------
......
(* This script parses OCaml's version and confronts it with a user-provided
version. It is meant to be run by invoking [ocaml checkOCamlVersion.ml]. *)
#load "str.cma"
(* This module parses ocaml version and confronts it with a user-provided
version. *)
(* According to OCaml's manual, the Sys.ocaml_version value follows the
regexp [version_regexp].
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment