Commit b99fe204 authored by POTTIER Francois's avatar POTTIER Francois

Fix the --suggest-link-flags options to use .cma and .cmxa extensions

instead of .cmo and .cmx. This should have been done earlier (when we
switched to automated installation via opam).
parent 9709a697
......@@ -346,9 +346,9 @@ let options = Arg.align [
"--strict", Arg.Set strict, " Warnings about the grammar are errors";
"--suggest-comp-flags", Arg.Unit (fun () -> suggestion := SuggestCompFlags),
" Suggest compilation flags for ocaml{c,opt}";
"--suggest-link-flags-byte", Arg.Unit (fun () -> suggestion := SuggestLinkFlags "cmo"),
"--suggest-link-flags-byte", Arg.Unit (fun () -> suggestion := SuggestLinkFlags "cma"),
" Suggest link flags for ocamlc";
"--suggest-link-flags-opt", Arg.Unit (fun () -> suggestion := SuggestLinkFlags "cmx"),
"--suggest-link-flags-opt", Arg.Unit (fun () -> suggestion := SuggestLinkFlags "cmxa"),
" Suggest link flags for ocamlopt";
"--suggest-menhirLib", Arg.Unit (fun () -> suggestion := SuggestWhereIsMenhirLibSource),
" Suggest where is MenhirLib";
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment