Commit a9e7fc51 authored by POTTIER Francois's avatar POTTIER Francois
Browse files

Add a [conflicts] clause to menhir{Lib,Sdk}.opam.

This tells opam that a new version of menhirLib or menhirSdk cannot
coexist with an old version of the menhir package (from the time
when menhirLib and menhirSdk were not separate packages).
parent 26de14d2
Pipeline #127231 passed with stages
in 26 seconds
......@@ -12,7 +12,10 @@ build: [
["dune" "build" "-p" name "-j" jobs]
]
depends: [
"ocaml" {>= "4.02.3"}
"dune" { >= "2.0.0"}
"ocaml" { >= "4.02.3" }
"dune" { >= "2.0.0" }
]
conflicts: [
"menhir" { != version }
]
synopsis: "Runtime support library for parsers generated by Menhir"
......@@ -12,7 +12,10 @@ build: [
["dune" "build" "-p" name "-j" jobs]
]
depends: [
"ocaml" {>= "4.02.3"}
"dune" { >= "2.0.0"}
"ocaml" { >= "4.02.3" }
"dune" { >= "2.0.0" }
]
conflicts: [
"menhir" { != version }
]
synopsis: "Compile-time library for auxiliary tools related to Menhir"
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment