Commit 97f7e215 authored by NICLAUSSE Nicolas's avatar NICLAUSSE Nicolas

conda recipe

parent 9ee5a299
......@@ -21,7 +21,7 @@
## ###################################################################
build
build*
build-*
## ###################################################################
## Install tree
......
# Version: $Id$
#
#
#
#
# Commentary:
#
#
# Commentary:
#
#
# Change Log:
#
#
#
#
# Code:
......@@ -17,8 +17,9 @@ channels:
- dtk
dependencies:
- qt >=5.9.0
- dtk-core >=2.3.0
- dtk-fonts
- dtk-log
#
#
# dtk-visualization.yaml ends here
@echo off
mkdir build
cd build
set BUILD_CONFIG=Release
cmake .. -G "Visual Studio 14 2015 Win64" ^
-Wno-dev ^
-DCMAKE_INSTALL_PREFIX=%LIBRARY_PREFIX% ^
-DCMAKE_PREFIX_PATH=%LIBRARY_PREFIX% ^
-DCMAKE_INSTALL_RPATH:STRING=%LIBRARY_LIB% ^
-DCMAKE_INSTALL_NAME_DIR=%LIBRARY_LIB%
if errorlevel 1 exit 1
cmake --build . --config %BUILD_CONFIG% --target install
if errorlevel 1 exit 1
#!/bin/bash
mkdir build
cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX="${PREFIX}" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_LIBDIR=lib
make -j${CPU_COUNT}
make install
package:
name: dtk-widgets
version: {{ GIT_DESCRIBE_TAG }}
source:
git_url: ../..
build:
number: 0
requirements:
build:
- cmake >=3.2.0
- binutils_impl_linux-64<2.31.0 # [linux]
- {{ compiler('cxx') }}
- {{ cdt('xorg-x11-proto-devel') }} # [linux]
- {{ cdt('mesa-libgl-devel') }} # [linux]
- {{ cdt('mesa-libegl-devel') }} # [linux]
- {{ cdt('mesa-dri-drivers') }} # [linux]
- {{ cdt('libx11-devel') }} # [linux]
- {{ cdt('libxext-devel') }} # [linux]
- {{ cdt('libxrender-devel') }} # [linux]
- {{ cdt('libxcb') }} # [linux]
- {{ cdt('libxau-devel') }} # [linux]
- {{ cdt('libdrm-devel') }} # [linux]
- {{ cdt('libxcomposite-devel') }} # [linux]
- {{ cdt('libxcursor-devel') }} # [linux]
- {{ cdt('libxi-devel') }} # [linux]
- {{ cdt('libxrandr-devel') }} # [linux]
- {{ cdt('pciutils-devel') }} # [linux]
- {{ cdt('libxscrnsaver-devel') }} # [linux]
- {{ cdt('libxtst-devel') }} # [linux]
- {{ cdt('libselinux-devel') }} # [linux]
- {{ cdt('libxdamage') }} # [linux]
- {{ cdt('libxdamage-devel') }} # [linux]
- {{ cdt('libxfixes') }} # [linux]
- {{ cdt('libxfixes-devel') }} # [linux]
- {{ cdt('libxxf86vm') }} # [linux]
host:
- qt >=5.9.0
- dtk-core >=2.3.0
- dtk-fonts
- dtk-log
run:
- qt >=5.9.0
- dtk-core >=2.3.0
- dtk-fonts
- dtk-log
about:
home: http://dtk.inria.fr/
license: BSD
summary: dtk-widget is a set of commonly used widgets written using Qt5.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment