Commit 746877b5 authored by Yannick Li's avatar Yannick Li
Browse files

Add README.md on top level and update specific README.md

parent 4969a710
# C - Sudoku
[![License](https://img.shields.io/badge/license-MIT-green)](https://opensource.org/licenses/MIT)
This repository contains two versions of Sudoku :
- A single-player version, used in the [tutorial](https://concordant.io/tutorial).
- A collaborative version, using the Concordant platform API.
......@@ -2,7 +2,7 @@
[![License](https://img.shields.io/badge/license-MIT-green)](https://opensource.org/licenses/MIT)
Sudoku using the Concordant platform API.
Collaborative Sudoku using the Concordant platform API.
## Setup guide
......@@ -10,7 +10,7 @@ Sudoku using the Concordant platform API.
For the next steps, you will need the following software:
- Make sure you have the latest version of Node.js: [see official installation guide](https://nodejs.org/en/download/);
- Make sure you have the latest version of Node.js (except Node v15): [see official installation guide](https://nodejs.org/en/download/);
- The project uses the CRDT library from Concordant private registry: [see Usage section](https://gitlab.inria.fr/concordant/software/c-crdtlib/-/blob/master/README.md).
1.**Install Project dependencies**
......@@ -32,4 +32,4 @@ npm start
Node: v14.15.0+
NPM: v6.14.8+
(Project might work with older Node and NPM versions)
(Project doesn't work with Node v15 but it might work with older Node and NPM versions)
......@@ -2,7 +2,7 @@
[![License](https://img.shields.io/badge/license-MIT-green)](https://opensource.org/licenses/MIT)
Sudoku using the Concordant platform API.
Single-player Sudoku.
## Setup guide
......@@ -10,8 +10,7 @@ Sudoku using the Concordant platform API.
For the next steps, you will need the following software:
- Make sure you have the latest version of Node.js: [see official installation guide](https://nodejs.org/en/download/);
- The project uses the CRDT library from Concordant private registry: [see Usage section](https://gitlab.inria.fr/concordant/software/c-crdtlib/-/blob/master/README.md).
- Make sure you have the latest version of Node.js (except Node v15): [see official installation guide](https://nodejs.org/en/download/);
1.**Install Project dependencies**
......@@ -32,4 +31,4 @@ npm start
Node: v14.15.0+
NPM: v6.14.8+
(Project might work with older Node and NPM versions)
(Project doesn't work with Node v15 but it might work with older Node and NPM versions)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment