Commit bcfd1f14 authored by Stephane Glondu's avatar Stephane Glondu

Calendar is a dependency of the web server

parent 6d1810cb
......@@ -75,7 +75,6 @@ To compile the command-line tool, you will need:
* [OCaml](http://caml.inria.fr/)
* [Findlib](http://projects.camlcity.org/projects/findlib.html)
* [Zarith](https://forge.ocamlcore.org/projects/zarith/)
* [Calendar](http://calendar.forge.ocamlcore.org/)
* [Uuidm](http://erratique.ch/software/uuidm)
* [Cryptokit](https://forge.ocamlcore.org/projects/cryptokit/)
* [Atdgen](http://mjambon.com/atdgen)
......@@ -85,7 +84,7 @@ To compile the command-line tool, you will need:
With OPAM, these dependencies can be installed with the following
command:
opam install atdgen zarith cryptokit uuidm calendar cmdliner
opam install atdgen zarith cryptokit uuidm cmdliner
Once all the dependencies have been installed, the command-line tool
can be compiled with:
......@@ -101,12 +100,13 @@ Web server
The web server has the following additional dependencies:
* [Calendar](http://calendar.forge.ocamlcore.org/)
* [Eliom](http://ocsigen.org/eliom/)
* [Csv](https://forge.ocamlcore.org/projects/csv/)
With OPAM, you can install them with:
opam install eliom csv
opam install calendar eliom csv
Once all the dependencies have been installed, the Eliom module can be
compiled with:
......
<**/*.{ml,mli,byte,native,odoc}>: debug, annot, package(uuidm), package(atdgen), package(yojson)
<src/platform/native/*>: package(zarith), package(calendar), package(cryptokit)
<src/web/*.{ml,mli,byte,native,odoc}>: thread, package(eliom.server), package(lwt.ppx), package(csv)
<src/tool/tool_cmdline.*>: package(zarith), package(calendar), package(cryptokit), package(cmdliner), use_platform-native
<src/platform/native/*>: package(zarith), package(cryptokit)
<src/web/*.{ml,mli,byte,native,odoc}>: thread, package(eliom.server), package(lwt.ppx), package(calendar), package(csv)
<src/tool/tool_cmdline.*>: package(zarith), package(cryptokit), package(cmdliner), use_platform-native
<src/tool/tool_js*> or <src/platform/js/*> or <src/booth/*>: package(js_of_ocaml), syntax(camlp4o), package(js_of_ocaml.syntax), package(lwt.syntax), use_platform-js
<**/*serializable_j.ml>: warn(-32)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment