Commit 4af6e4f2 authored by Stephane Glondu's avatar Stephane Glondu

Update installation documentation

parent 0070f0d5
......@@ -63,11 +63,12 @@ To compile the command-line tool, you will need:
* [Cryptokit](https://forge.ocamlcore.org/projects/cryptokit/)
* [Atdgen](http://mjambon.com/atdgen)
* [Yojson](http://mjambon.com/yojson.html)
* [Cmdliner](http://erratique.ch/software/cmdliner)
With OPAM, these dependencies can be installed with the following
command:
opam install atdgen zarith cryptokit uuidm calendar
opam install atdgen zarith cryptokit uuidm calendar cmdliner
Once all the dependencies have been installed, the command-line tool
can be compiled with:
......@@ -128,7 +129,7 @@ official Debian packages. On Ubuntu, you need to enable the "Universe"
repository. Instead of using OPAM, the dependencies of Belenios can
then be installed with:
sudo apt-get install libatdgen-ocaml-dev libzarith-ocaml-dev libcryptokit-ocaml-dev libuuidm-ocaml-dev libcalendar-ocaml-dev
sudo apt-get install libatdgen-ocaml-dev libzarith-ocaml-dev libcryptokit-ocaml-dev libuuidm-ocaml-dev libcalendar-ocaml-dev libcmdliner-ocaml-dev
sudo apt-get install ocsigenserver eliom libcsv-ocaml-dev
Compiling on Windows using Cygwin
......
......@@ -87,7 +87,7 @@ eval `opam config env --sh`
echo
echo "=-=-= Installation of Belenios build-dependencies =-=-="
echo
opam install --yes atdgen zarith cryptokit uuidm calendar eliom csv
opam install --yes atdgen zarith cryptokit uuidm calendar cmdliner eliom csv
echo
echo "=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-="
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment