Verified Commit 5414b272 authored by Raphaël Bleuse's avatar Raphaël Bleuse
Browse files

Remove path dependencies

parent 486e580e
......@@ -55,26 +55,18 @@ python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
[[package]]
name = "pybatsim"
version = "4.0.0-alpha.0"
version = "4.0.0a0"
description = "Python API and schedulers for Batsim"
category = "main"
optional = false
python-versions = "^3.7.1"
develop = true
python-versions = ">=3.7.1,<4.0.0"
[package.dependencies]
docopt = "^0.6.2"
docopt = ">=0.6.2,<0.7.0"
importlib-metadata = {version = ">=3.6", markers = "python_version < \"3.10\""}
procset = "^1.0"
pyzmq = "^22.0.3"
sortedcontainers = "^2.3.0"
[package.extras]
tools = ["pandas (>=1.3.4,<2.0.0)"]
[package.source]
type = "directory"
url = "../pybatsim-core"
procset = ">=1.0,<2.0"
pyzmq = ">=22.0.3,<23.0.0"
sortedcontainers = ">=2.3.0,<3.0.0"
[[package]]
name = "pycparser"
......@@ -127,7 +119,7 @@ testing = ["pytest (>=6)", "pytest-checkdocs (>=2.4)", "pytest-flake8", "pytest-
[metadata]
lock-version = "1.1"
python-versions = "^3.7.1"
content-hash = "d62bb5a62ffeb20015bd1df9ffa1bf943c9f75aa0e0db0d7c8cdf2fd975cf3ee"
content-hash = "1d0a15759a585ec9f5c4946b9404a381d9b9e63a15c748a32c7ecaa6ce5af803"
[metadata.files]
cffi = [
......@@ -197,7 +189,10 @@ py = [
{file = "py-1.11.0-py2.py3-none-any.whl", hash = "sha256:607c53218732647dff4acdfcd50cb62615cedf612e72d1724fb1a0cc6405b378"},
{file = "py-1.11.0.tar.gz", hash = "sha256:51c75c4126074b472f746a24399ad32f6053d1b34b68d2fa41e558e6f4a98719"},
]
pybatsim = []
pybatsim = [
{file = "pybatsim-4.0.0a0-py3-none-any.whl", hash = "sha256:2c27155c6291784f94f38c0a637c0c8675ac3219908c8b6c694fc3ff24f52578"},
{file = "pybatsim-4.0.0a0.tar.gz", hash = "sha256:97c4196862f9259b0919e16402e905ba31a6c93be76993ae0e326c2542e41dff"},
]
pycparser = [
{file = "pycparser-2.21-py2.py3-none-any.whl", hash = "sha256:8ee45429555515e1f6b185e78100aea234072576aa43ab53aefcae078162fca9"},
{file = "pycparser-2.21.tar.gz", hash = "sha256:e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206"},
......
......@@ -13,7 +13,7 @@ packages = [
[tool.poetry.dependencies]
python = "^3.7.1"
pybatsim = {path = "../pybatsim-core", develop = true}
pybatsim = "^4.0.0a0"
[tool.poetry.plugins."pybatsim.schedulers"]
rejector = "universal_rejection:UniversalRejectionScheduler"
......@@ -87,23 +87,18 @@ python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
[[package]]
name = "pybatsim"
version = "4.0.0-alpha.0"
version = "4.0.0a0"
description = "Python API and schedulers for Batsim"
category = "main"
optional = false
python-versions = "^3.7.1"
develop = true
python-versions = ">=3.7.1,<4.0.0"
[package.dependencies]
docopt = "^0.6.2"
docopt = ">=0.6.2,<0.7.0"
importlib-metadata = {version = ">=3.6", markers = "python_version < \"3.10\""}
procset = "^1.0"
pyzmq = "^22.0.3"
sortedcontainers = "^2.3.0"
[package.source]
type = "directory"
url = "../pybatsim-core"
procset = ">=1.0,<2.0"
pyzmq = ">=22.0.3,<23.0.0"
sortedcontainers = ">=2.3.0,<3.0.0"
[[package]]
name = "pycparser"
......@@ -183,7 +178,7 @@ testing = ["pytest (>=6)", "pytest-checkdocs (>=2.4)", "pytest-flake8", "pytest-
[metadata]
lock-version = "1.1"
python-versions = "^3.7.1"
content-hash = "88e2f37774afc8542a35050fc8ad068ff69ed12f4712f58287a27c31fc7192af"
content-hash = "326c4ef6e6b9d2b52b10f1c39833aadcab818ba6c654e5f7ad2ac25966fce797"
[metadata.files]
cffi = [
......@@ -325,7 +320,10 @@ py = [
{file = "py-1.11.0-py2.py3-none-any.whl", hash = "sha256:607c53218732647dff4acdfcd50cb62615cedf612e72d1724fb1a0cc6405b378"},
{file = "py-1.11.0.tar.gz", hash = "sha256:51c75c4126074b472f746a24399ad32f6053d1b34b68d2fa41e558e6f4a98719"},
]
pybatsim = []
pybatsim = [
{file = "pybatsim-4.0.0a0-py3-none-any.whl", hash = "sha256:2c27155c6291784f94f38c0a637c0c8675ac3219908c8b6c694fc3ff24f52578"},
{file = "pybatsim-4.0.0a0.tar.gz", hash = "sha256:97c4196862f9259b0919e16402e905ba31a6c93be76993ae0e326c2542e41dff"},
]
pycparser = [
{file = "pycparser-2.21-py2.py3-none-any.whl", hash = "sha256:8ee45429555515e1f6b185e78100aea234072576aa43ab53aefcae078162fca9"},
{file = "pycparser-2.21.tar.gz", hash = "sha256:e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206"},
......
......@@ -34,7 +34,7 @@ packages = [
[tool.poetry.dependencies]
python = "^3.7.1"
pybatsim = {path = "../pybatsim-core", develop = true}
pybatsim = "^4.0.0a0"
pandas = "^1.2.3"
[tool.poetry.dev-dependencies]
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment